Erik_
Package arrived full of Atari 400 awesomeness!
Sat Aug 06, 2022 1:59am

Package arrived some point yesterday. I didn't notice it until I brought my kid outside after work. For some reason it was all the way by the sidewalk but still inside the gate. Hopefully the UPS guy was just lazy and dumped it over the fence instead of someone starting to steal it before having a change of heart/too many witnesses. In any case, it's here!

Thank you so much for all this stuff! That was really really generous of you. I know in a previous post I said I was done porting Wry for a bit, but I might have to take that on as a first Atari Basic project (at least "Wry Lite" or something).

Everything cleaned up really well with some rubbing alcohol and scrubbing.

Here's the run down after opening / fiddling with things all last night and tonight as well:
* Tape drive - Record button seems like it might be stuck? I haven't tried putting a tape in, I'm thinking maybe it just has a mechanical switch/lever that blocks it from being pressed. It definitely gets power and I can hear the motor moving when I FF or REW. I'm about 95% sure the belt needs to be replaced and it should work.
* Floppy drive - from what I can tell, it looks to be working. Giving it power it moves the head around and does it's "power on" boot stuff. The face plate seems to be knocked a little bit off on the one corner. Not sure if that was shipping or it was like that. I think when I open it up to clean the head I'll be able to get it back in place.
* Power supplies - Both work. Double checked the output voltage of each one and they both read good over a period of time.
* Atari 400 - Looks like there's going to be some work to be done here....

After I cleaned it up, I brought it into the living room with the games and was checking to see if it would load up.

I couldn't get the BASIC cart to do anything. :(
The Star Wars arcade cart was the same...
Popeye started up and looked great after a few retries pulling it in and out. I didn't have a controller plugged in and it didn't seem like it had keyboard controls. The game randomly crashed during the "attract" screen and I had to restart it but it came back.
Pac Man took a few tries too but started up. This one I had a bit to test some things out. Also didn't have keyboard controls that I could figure out except that space bar paused the game. The 4 buttons on the right side to reset, select and such all worked.

Unfortunately, that was the last time I got it to really boot up for any period of time. After that Pac Man test, I figured I'd try the BASIC cart again and no luck. Swapping back in Popeye and PacMan also didn't work anymore, I just got a green screen.

So, I took the whole thing apart. I figured maybe it was just the CPU board or RAM board that needed some contact cleaner. I did that, and didn't see much of a difference.

After work today, I wiggled things around and tried booting without a cartridge so it would load that Atari "Memo Pad" thing. Figured that would at least take the cartridge port out of the equation. After a few tries it actually did go to the memo pad! It stayed there for a few seconds then the screen freaked out. It filled with characters that were like 4x normal size and the crashed. I wasn't able to boot it up again after that.

I noticed when it actually loads up, the speaker makes a sad "umph" noise. When I get the green or black screen it doesn't make any noise.

I ran out of contact cleaner (more coming Monday) but I still decided to re-seat all the socketed chips on all 3 boards. Everything looked pretty clean except the POKEY chip and a logic chip near it. It had some crazy corrosion once I pulled them.

Here's some pics:
https://i.imgur.com/2G5zHhs.jpg
https://i.imgur.com/tCgMYbC.jpg

Not fully cleaned due to not having anymore cleaner and using rubbing alcohol the best I could, but reinserted (with a bonus hair on the board):
https://i.imgur.com/pc9Wk5Q.jpg

Nothing seemed to change after doing all that unfortunately. After looking it up, the POKEY chip is responsible for I/O stuff from the controllers and stuff so even if that was bad, I wasn't even getting to that part of testing yet to find out. The logic chip to its right though, I'm not sure what it does. Maybe after I clean it a bit more things will change?

So, I let it sit for a bit tonight while I searched online about possibly picking up another ANTIC chip or some more RAM chips to swap out. Out of curiosity that it was the OS ROM or the floating point math chip that was bad, I decided to try again with a cartridge. Apparently the computer will boot and run most games with the math chip not even installed. I guess if it doesn't use it, it doesn't care.

So, just now I tried trusty "Popeye". Nothing booted to the screen but I did actually hear the speaker make a little noise and the screen was black instead of green. So it tried to boot again after sitting! After trying to turn it off and on again, I was back to nothing happening and a green screen.

I should also note, I the power supply board is sending the right voltage to the main motherboard. I checked those voltages and they all checked out. I didn't see any crazy spikes on the motherboard or to the connectors to the daughter boards. There were a few resistors that didn't have any voltage on either side for some reason. They might have been controller related so just not active when the computer was idle.

I eBayed a copy of Star Raiders for cheap just now. I read that it has a diagnostic something built in where if it works, you know that the OS chip is bad. Plus, when I get the thing running Star Raiders is awesome. I've only played the Atari 2600 version so I'm excited to see what the 8bit computer version is like.

I'm tempted to race and buy new chips for the RAM or CPU board but I'm going to wait until I get the contact cleaner and reset/clean with that first. Hopefully I don't have to go that route but we'll see.

Again, that you so much! This has been fun troubleshooting/messing with so far! :)

(I think this might be my longest message on this site that isn't just random characters or something)


    • You're welcome! Glad it can be enjoyed - Puckdropper, Sat Aug 06 2022 4:04am
      Press the play button at the same time as record and let's see what happens. Many of those old tape drives were like that, partially as an accident prevention feature and probably because you wanted to do everything Play did anyway (bring the head close to the tape, turn on the motor, etc). You may... more
      • Still no luck so far.. - Erik_, Tue Aug 09 2022 10:56am
        My contact cleaner spray came so last night I went through and pulled all the chips again and cleaned everything a bunch. I used over a whole can on the parts. Once everything was back together, still the same issue. Black/greenish screen with nothing coming up. The TV is getting a signal from the... more
        • There's a good chance that unknown and unknown will work - Puckdropper, Wed Aug 10 2022 2:12am
          As long as it's not a common failure mode for that model. Have you thought about checking the traces around the corroded areas? A black/greenish screen kinds sounds to me like a signal isn't getting somewhere it should. Of course ICs weren't as robust as they are now and even modern RAM goes bad.... more
          • PROGRESS! - Erik_, Fri Aug 12 2022 1:54am
            This has been my view for the past week at night when I have some time: You can see my 5200 to the left, also taken apart. Here's the innards of that system: So apparently the 5200 is basically a stripped down/modified Atari 400. It uses the same CPU, ANTIC, and GTIA chips as the late... more
            • Wow, that's awesome! And that case has never looked so good! - Puckdropper, Fri Aug 12 2022 3:18am
              It kinda makes sense that Atari would reuse most of a design. After all, it's almost all there why not just remove or add the bits you need and make it a new system. Be sure to clean that flux off before closing things up. Even no-clean flux should really be cleaned. A method I was recently introduced... more
"Forces act when not restrained" - Puckdropper